Hot answers tagged

4

when I use address=/#/127.24.2.1, the internet requests that go from internal scripts also fail It seems that your internal scripts use to resolve DNS names the same local dnsmasq server as you wifi clients. Check your /etc/resolv.conf configuration and if there is present your dnsmasq server address (127.24.2.1 or 127.0.0.1 or other) - remove it. ...


3

Of course the performance will be degraded after so many traversals. Radio is a shared medium (half-duplex), collisions can happen and to avoid them Wi-Fi uses CSMA/CA. Your performance will at least be degraded more than in half. Every client adds to the latency


3

In case anyone is curious about an update (in 2017) to this question... I was able to recreate the issue and figured out a solution. Disable dnsmasq from resolving for the loopback interface (in /etc/dnsmasq.conf): except-interface=lo Add to the tail file of resolvconf (in /etc/resolvconf/resolvconf.conf.d/tail) nameserver 8.8.8.8 Restart Services sudo ...


3

You are making a few different mistakes in your configuration. First of all site-local addresses have been deprecated for many years. Any documentation telling you to use addresses starting with fec0 is outdated and needs to be updated. The replacement for site-local addresses is called unique local addresses. These are constructed by using fd as the first ...


2

In your hostapd.conf: # Module bitfield (ORed bitfield of modules that will be logged; -1 = all # modules): # bit 0 (1) = IEEE 802.11 # bit 1 (2) = IEEE 802.1X # bit 2 (4) = RADIUS # bit 3 (8) = WPA # bit 4 (16) = driver interface # bit 5 (32) = IAPP # bit 6 (64) = MLME # # Levels (minimum value for logged events): # 0 = verbose debugging # 1 = debugging ...


2

Try to set wpa=2 this configuration worked for me interface=wlan0 ssid=$SSID hw_mode=g wpa=2 ieee8021x=0 eap_server=0 ignore_broadcast_ssid=0 wpa_passphrase=$PASSWORD wpa_key_mgmt=WPA-PSK wpa_pairwise=TKIP rsn_pairwise=CCMP channel=5


2

The issue is with rtl8192cu (the driver). It doesn't support AP mode properly at the moment. It may seem to work, showing the device in master mode, but you won't get any beacons or traffic moving through. Read through this thread - http://www.spinics.net/lists/linux-wireless/msg96070.html - hopefully one of the developers will pick up on what is missing to ...


2

You need to specify dnsmasq which interface to use what network. You can do this with below change in your dnsmasq.conf file: dhcp-range=ap0,192.168.12.20,192.168.12.150,255.255.255.0,12h dhcp-range=ap1,192.168.13.20,192.168.13.150,255.255.255.0,12h or, dhcp-range=interface:ap0,192.168.12.20,192.168.12.150,255.255.255.0,12h dhcp-range=interface:ap1,192....


1

You can decrease the verbosity of wpa_supplicant by using -q or even -qq. See: https://linux.die.net/man/8/wpa_supplicant


1

Radius strings may be any valid UTF8 sequence. There's no limitations on what characters can be used for a user's password or for their username.


1

If in-country connectivity is good, then the bottleneck is most likely your ISP. It's definitely not related to your AP. It's either the connectivity between your country and others, or your ISP may just not have good connectivity to foreign sites. You may be able to narrow it down by doing some traceroute tests to foreign sites to see if there's an obvious ...


1

In man page of dnsmasq there is a option saying -l, --dhcp-leasefile=<path> Use the specified file to store DHCP lease information. So, you can use a file to log it. And the format of the file is: 946689575 00:00:00:00:00:05 192.168.1.155 wdt 01:00:00:00:00:00:05 946689522 00:00:00:00:00:04 192.168.1.237 * 01:00:00:00:00:00:04 946689351 00:...


1

I suggest you to use radiotap for example https://wireless.wiki.kernel.org/en/users/documentation/packetspammer you only need in this case to assemble packets manually To see how what's going on - use https://wiki.wireshark.org/CaptureSetup/WLAN#WLAN_.28IEEE_802.11.29_capture_setup


1

I met the similar problem with hostapd_1.0-3+b1_armhf.deb several days ago, when i setup wpa on my ap (raspberry pi), evenif the passpharse was inputted correctly, the connection always failed by password authentication. After trying a newer version(hostapd_2.1-0ubuntu4_armhf.deb), the problem is gone. I don't know the reason of this issue, looks like it ...


Only top voted, non community-wiki answers of a minimum length are eligible