The Stack Overflow podcast is back! Listen to an interview with our new CEO.

Hot answers tagged

55

There are several things you can do: 1. Application Initialization You can use Application Initialization Module which comes in-box with IIS 8.0 you can have something like this in your web.config <applicationInitialization doAppInitAfterRestart="true" > <add initializationPage="/" /> </applicationInitialization> This will send ...


36

You could chose any of the websites hosted in IIS and uncheck SNI (Server Name Indication there. Check this below


35

We had the same error on a brand new server. The reason was not the default IIS security policy, stored in applicationHost.config, as suggested by the other answer (although we checked that). The reason was that we installed IIS without support for ASP.NET (an ASP.NET 4.5 role)! When we installed the missing support for ASP.NET, our application just ...


25

I wouldn't consider it a good practice. When most people usually set up things like "nightly iisresets" or "nightly reboots," generally, it's because they are running an application that is poorly-written and leaks resources, to the point where the entire system may become unstable unless we restart the application, the service, or even entire system. The ...


24

First to specifically answer your question; "How can i change that to DHE_RSA or ECDHE_RSA?" The easiest solution to this is to download IIS Crypto and let it do the hard work for you. IIS Crypto In order to use DHE_RSA or ECDHE_RSA you'll need to re-order the cipher suite preferences in the bottom left pane of the IIS Crypto window. I currently set ...


22

I ran into the same issue with a GoDaddy SSL certificate on Windows 2012 / IIS 8. What worked in my case, after getting the "Failed to Remove Certificate" error, was this: I have tried adding it again, this time getting an "Access Denied" error. I have also tried adding it to the "Personal" store instead of "Web Hosting" but same "Access Denied" error ...


15

Open an elevated command-prompt or PowerShell: dism /online /enable-feature /featurename:IIS-BasicAuthentication Now you will have the Basic Authentication option in the Authentication page in IIS Manager. This works in Server Core and is much quicker than using the GUI.


15

Ok, the problem was I trusted Web Platform... Installing defaults settings for Web Deploy 3.5 didn't install all required components like: You need to install "IIS Deployment Handler" to be able to use it.


13

Are you 100% sure he is not testing with a higher or lower version of TLS, packet resets normally are attributed to the application not knowing what to do with it.


12

You write that you can't figure out how to retrieve: Physical Path is directly accessible through the physicalPath noteproperty App Pool Association doesn't make sense, Applications are assigned to app pools, directories themselves are not Site Name You already know this ($Site.name) Credentials I assume you just want the username if present These ...


12

Hello and Sorry for bumping a bit old thread. AFAIK Applicure DotDefender is not compatible with Windows Server 2012 R2. I tried it With Server 2012 R2 vs IIS 8.5 it isn't working anymore. Here is whitepaper (that is written by me) regarding how to Protect IIS 8.5(or any Windows Web srv) using Apache~ mod_proxy + DotDefender 5.13. Sorry, it is written in ...


10

Open your IIS manager and select the directory you want to protect. Under the "IIS" section select "Authentication". Disable "Anonymous Auth". Enable the desired Auth method (usually "Basic Auth") and it will be valid for this directory only. Add a User account. Give that user Read, Execute, List Permissions on the directory needed, then login via the newly ...


9

In Server 2012, go to Add Roles and Features. If you have not installed the Web Server Role, be sure to select that from the Server Roles section. When you get to the Role Services page for the Web Server Role, you will have the option to select IIS 6 Management Compatibility.


9

I had the same problem and I found out that it require to run IIS Manager with administrator permissions. Try to run IIS Manager as Administrator and it should solve the problem. Or try to access the manager console from Computer Management (mmc), which must be run with Administrator privileges.


8

In server manager, in Web Server (IIS)/Security, add Basic Authentication which then should show up in IIS web site authentication settings.


8

Yes, totally outdated, in fact it was never ever required or good practice. If you had to do this there was something wrong with your application. Recycling application pools is a much cheaper operation as it just shuts down one process and starts another one. Iisreset restarts the whole IIS with all its components. AppPool recycling also gives you much ...


7

I was able to solve my own problem using IIS Rewrite Mod. I was little confused when found this, since Rewrite Mod is well know in Unix world with the Apache Web Server. Anyway, just downloaded and installed the IIS Rewrite Mod from here: http://www.microsoft.com/en-us/download/details.aspx?id=7435 And then modify web.config in wwwroot with this XML code: ...


7

Open Server Manager At Server Level (not default Web site) Double click FastCGI Settings open PHP.EXE listed there Monitor changes to file php.ini activity timeout default is 60s - change to 600s or whatever


7

i do this in IIS 8 $testpool = get-item iis:\apppools\$iisAppPoolName; $testpool.processModel.userName = $un; $testpool.processModel.password = $pw; $testpool.processModel.identityType = 3; $testpool | Set-Item $testpool.Stop(); $testpool.Start(); Works for me :)


7

I can ping6 the IP address noted above from my office. PING 2001:4ba0:cafe:c54::1(2001:4ba0:cafe:c54::1) 56 data bytes 64 bytes from 2001:4ba0:cafe:c54::1: icmp_seq=1 ttl=115 time=41.2 ms 64 bytes from 2001:4ba0:cafe:c54::1: icmp_seq=2 ttl=115 time=33.4 ms 64 bytes from 2001:4ba0:cafe:c54::1: icmp_seq=3 ttl=115 time=34.8 ms When I access the ...


6

Yes, you just create a Virtual Directory off of site.com. You can give it a path on a local physical drive or an UNC path to a remote resource (assuming you have the appropriate permissions). In IIS Manager: Right-click the site.com site and choose Add Virtual Directory... In the Alias box enter uploads In the Physical Path box enter the path to your ...


6

Below are the Classic ASP Debugging Properites default settings: All you need to change here is Send Errors To Browser = True This should give you the real error in a browser on the server. To see that error in a remote computer click on the Error Pages icon for the site in IIS Manager and click Edit Feature Settings in the Actions pane on the right. ...


5

I ran into a Similar Issue. I had to download the certificate as a .P7B file, Install the Certificate into the local Cert Store, then Export the Certificate as a .PFX with a Password. Right Click the Cert and Click Install, You can choose Automatic, or the 'The Following Store' I believe Automatic installs it into Local Computer/Personal. So in MMC, load ...


5

Go to Server Manager, or type "servermanager" at a command prompt. The GUI Server Manager will pop up. Click the Manage dropdown up in the top right. Choose "Add Roles and Features." Click next, next, select the right server, click next. Now you should be on the Server Roles selection. Expand IIS (which will be greyed out since you have already ...


5

The most likely problem is Windows Firewall. Configure it to allow port 8080 traffic. It allows port 80 by default when IIS is installed as a role, but it doesn't automatically configure itself if you change the port.


5

DNS has nothing to do with this. You need to edit the IIS site in question to accept requests for that host header. Using IIS Manager, open up the Sites node and choose the site you want the host header to work on. In the Actions pane, click Bindings. Then choose the binding you want to add a host header to and click Add. Type in a host header, for example ...


5

To clarify because there seems to be some confusion here, you need to click on the IIS server - not the site. Add your certificate. Then click on the site that will use it and bind the certificate to that site.


5

There is a simple way to do, tick the "Require Server Name Indication" in "Bindings...". Reference: https://stackoverflow.com/a/27791857/3260008


4

I like to require SSL and bounce the 403.4 error to https://domain/owa on the root and OWA applications.


4

You should disable anonymous authentication for the directory if there is no need to have anonymous users. This will take care of the problem


Only top voted, non community-wiki answers of a minimum length are eligible