New answers tagged

0

File /etc/network/interfaces Result config auto lo iface lo inet loopback iface enoX inet manual # there are some unused internal network interfaces auto enp101s0f0 iface enp101s0f0 inet static address x.y.z.2 netmask 255.255.255.240 gateway x.y.z.1 iface enp101s0f0 inet6 static pre-down ip -6 addr flush dev enp101s0f0 scope global || : ...


8

ignoreip is space delimited. Delete the comma. Confirm the address is correct by cross referencing all the IPs on the host to allow, with the logs of the service in question. Consider allowing nets of yours rather than single IPs for v6 as well. For example, 2a02:2020:2020::1/64.


1

My personal setup, that works. It uses docker's internal default bridge instead of users supplied networking. /etc/docker/daemon.json { "ipv6": true, "fixed-cidr-v6": "2a02:168:7a0e:11::/64" } docker-compose.yml version: '3.3' services: shell: networks: - bridge image: centos:8 networks: bridge: ...


4

It's a technically possible value for the field, but as you noted it's not really valid in the sense that . isn't actually the name of a nameserver. Unlikely, as the SOA MNAME isn't really used for normal lookups. While the NS records are crucial for finding nameservers in the normal lookup process, the SOA MNAME is only used in some specific cases where it ...


0

You can just declare a normal port forward during container creation, using -p [2001:dead:beef::1]:22:22 That creates an IPv6 socket on the host that is forwarded to an IPv4 socket inside the container. To listen to any IPv6 address, use [::] as the listen address.


2

This is the lesson not to use security scripts without understanding any single line. I suspect this part is a culprit: # Reject connection attempts not initiated from the host $ipt6 -A INPUT -p tcp --syn -j DROP It really disables any incoming TCPv6 communication. It also must disable any "related" TCPv6 communication (for instance, "active&...


3

ULA is not for routing to the internet. It will get dropped before leaving your network resulting in a bad user experience. Remove the ULA net from ocserv configuration and replace it with one or more /64 from your address plan. These subnets are only for the VPN. For example: ipv6-network = 2001:db8:3025:1407::/64 On VPN clients with a web browser, verify ...


2

While your answer apparantly works for you, it does seem overly complicated. I'm doubtful though that it does what you want, as it lacks any IPv4 addresses in the given output (apart from lo). Creating 2 tagged interfaces (named e.g. vlan4 and vlan6), assigning them IPv4 and IPv6 addresses + gateways, and disabling SLAAC with sysctl for the IPv4 one should ...


1

I have found a solution. Because I want to manipulate VLANs, I have to use a bridge. VLAN is working on OSI layer 2 and a bridge is the device that can handle layer 2 protocols. So first I added two VLAN interfaces to the physical interface eth1. Then added all interfaces eth0, vlan4 and vlan6 to the bridge. The rest is done by nftables. IPv4 and IPv6 are ...


1

I've fixed the issue with issuing the command and restarting the server netsh interface ipv6 reset Thanks a lot


0

Can't remember where I found this solution, but here it is In /etc/bind/named.conf.local: // disable lookup over IPv6 server ::/0 { bogus yes; }; It then pretends that IP addresses in the IPv6 range are non reachable and does it with IPv4 instead.


Top 50 recent answers are included