New answers tagged

0

From my experience, Windows guests usually munch too much CPU when a virtual hardware driver is set to something less than ideal. The settings I usually make are: Storage should always be VirtIO-SCSI. You can just change this setting for an existing VM if the VirtIO-SCSI driver is already installed in the guest, but installing new guests requires you also ...


0

I've figured it out: -device virtio-net-pci,mac=${MAC1},netdev=${BRIDGE1} \ -netdev bridge,br=${BRIDGE1},id=${BRIDGE1} \ -device virtio-net-pci,mac=${MAC2},netdev=${BRIDGE2} \ -netdev bridge,br=${BRIDGE2},id=${BRIDGE2} The above configuration has the same effect as the one I posted in the question and there's no loop.


0

The tutorial you linked to provides directions to install libvirtd, but then it never actually uses it anywhere. Instead it advises creating VMs manually, which is completely insane, not least because their configuration isn't saved anywhere. Use libvirt-aware tools such as the virt-manager GUI or virt-install to create virtual machines with libvirt.


2

The qemu binary shipped by default in RHEL does not support snapshot live merging. To merge your snapshot, you have two possibilities: shutdown the virtual machine and use qemu-img(see here for an example) install the qemu-kvm-ev package from CentOS Virtualization SIG, which has the required functionality.


0

So what was indeed helpful is: <controller type='usb' index='0' model='none'/> <clock offset='utc'> <timer name='hpet' present='yes'/> <timer name='hypervclock' present='yes'/> </clock> Reduced my "idle" load on host system by nearly 10% (in top). Thank you!


0

When booting a VM in BIOS mode there is no such thing. When booting a VM in EFI mode use ESC key to enter EFI (make sure to click on the pane to get focus).


0

Finally I solved my issue: Solution: On the host site everything was ok. This is some issue with Debian I installed. I logged there via virt-viewer, then I modified /etc/network/interfaces: # This file describes the network interfaces available on your system # and how to activate them. For more information, see interfaces(5). source /etc/network/...


0

You attach both the default and host-bridge networks to the domain. Don't do that. Using the netplan-defined bridge you'd replace --network network=default \ --network network=host-bridge with --network=host-bridge That should fix your problem as the guest will attempt to configure the first interface with DHCP. I'd also disable STP on the bridge. ...


1

On the host system check state of the br0 interface. It should be up. In your case you should configure the ens4 interface in the guest system. This interface corresponds to your bridging network. Also, you shouldn't assign any ip address on the eno2 interface, because it's a bridge port interface (slave of the br0 interface). Other things seem like ...


1

Use DHCP reservations to always assign the same ip address to each machine.


1

You can use several ways to use a public ip inside a VM. First way is that, what you've chosen. In this case you create a bridge interface with eth1 as bridge port. Your interfaces file should be look something like. iface br0 inet static bridge-ports eth1 bridge_stp off bridge_fd 0 bridge_maxwait 0 address xxx.yyy.zzz.130 netmask ...


-1

cron this in the VM and/or VM host every night after busy hours: sync; echo 1 > /proc/sys/vm/drop_caches it drops the fs cache and gives it back as available memory to the system then the KVM/Hypervisor can see it as free memory and find other uses for it also works very well with docker systems


0

I prefer (and use) the answer by Ciro Santilli, but here's something that works with a guestfish shell: # assumes extant directory "rootfs" tar -cf rootfs.tar -C rootfs . guestfish <<EOF disk-create rootfs.qcow2 qcow2 "$((2 * $(stat -c%s rootfs.tar)))" add-drive rootfs.qcow2 run part-disk /dev/sda gpt mkfs ext4 /dev/sda mount /dev/sda / tar-in rootfs....


1

KVM is a kernel module, not a hypervisor that you can use.I guess you are referring to the -cpu option in QEMU? Here accelerator refers to KVM. You can use other accelerators by using the -accel option. The -cpu help flag gives you a pretty good explanation. -cpu max means emulate a cpu that has all the features supported by KVM (limited by the set of ...


1

You can try to use virt-convert, for example virt-convert foo.vmx --disk-format qcow2 --destination /tmp/test


0

Remove the autostart from the network definition. It is being started by the network manager. The two configurations may be conflicting. virsh may report the interace as inactive even if it is up. Whatever you define your bridge as, it neeeds to be declared to libvirt. You will need to ensure the network configuration is complete. Alternatively, you ...


1

I managed to reduce the CPU usage by following the instructions from https://marc.info/?l=openbsd-misc&m=151575775607633&w=2. Below example of my OpenBSD 6.4 virtual machine config file: <domain type='kvm'> <name>openbsd</name> <uuid>6ab7f964-06f2-4526-b5a7-c5cc1ff22254</uuid> <metadata> <libosinfo:...


0

Someone has created a manual configuration for the virbr0 virtual bridge interface, which is supposed to be managed by libvirt. The instructions you linked to state that it should instead be created for the br0 bridge interface. You should change all occurrences of virbr0 in those ifcfg- files to br0. The name actually does not matter, but it must not be ...


Top 50 recent answers are included