Hot answers tagged

79

systemd completely ignores /etc/security/limits*. If you are using an RPM that auto-squashes its systemd service file on update, you'll want to file a PR to ask them to mark those files as 'noreplace' You need to update the .service file /usr/lib/systemd/system/<servicename>.service [Unit] Description=Some Daemon After=syslog.target network....


44

Should anyone stumble across this, i found the solution here: https://ask.fedoraproject.org/en/question/43459/how-to-start-mysql-mysql-isnt-starting/ Repost below To start MariaDB on Fedora 20, execute the following command: systemctl start mariadb.service To autostart MariaDB on Fedora 20, execute the following command: systemctl enable mariadb.service ...


39

Maria-DB is not a performance-enhanced MySQL version. Maria-DB is the forked MySQL version current used in the open-source space. It was forked from MySQL due to mistrust in how Oracle will behave in regard of the original MySQL code. You can see here for more information. While until version 5.1 both were more or less the same code, by 5.5 this changed ...


29

If you haven't any real data in your database then clear all in /var/lib/mysql. After that try again to run command mysql_install_db --user=mysql --basedir=/usr --datadir=/var/lib/mysql to initialize database directory.


21

Yes, it is possible. (I figured this out while writing the question) Install MariaDB in the new Arch system, verify that it works. Do your changes to the /etc/mysql/my.cnf. E.g. innodb_file_per_table. (more of this is out of scope for this question) sudo systemctl stop mysqld. (You want to stop on both servers, but in my case the other was already off) ...


21

Given the above, we felt that ruled out an issue with the DB itself. We did verify that each user was using the same mysql client and had similar ENV/PATH setups. After giving it some thought we had 'User A' to start the client in verbose mode, which gave us our answer. -bash-4.3$ mysql --verbose -u userA -A Welcome to the MySQL monitor. Commands end with ;...


18

That behaviour sounds consistent with enabling the plugin for socket authentication for the root user, where MariaDB trusts operating system credentials received over the socket and does not rely on a password. By using sudo or logging on as root you can connect to the database server as root, because you're root on the OS, but other OS users can't. You ...


16

I was able to install the MariaDB 5.5 CentOS repository list (created 2016-05-09 04:06 UTC). Create the following file: sudo vi /etc/yum.repos.d/maria.repo Add the following contents to the file and save: [mariadb] name = MariaDB baseurl = http://yum.mariadb.org/5.5/centos6-amd64 gpgkey=https://yum.mariadb.org/RPM-GPG-KEY-MariaDB gpgcheck=1 Then run ...


15

When you run: yum install mysql command by default it installs MariaDB not MySQL. So try the following command: yum list installed | grep mariadb if mariadb-server is missing try this following command: yum install mariadb-server it installs the server package then start the service: systemctl start mariadb or: service mariadb start My issue was ...


13

That behaviour is by design, which as far as I know you can not override. By default all interactive statements are logged, including the CREATE USER statement, except when they contain password information. Although you can add extra conditions that will prevent logging certain additional statements (set either the --histignore option or the ...


11

One of the ways to find out your current log file path is using the following SQL query: show global variables like 'log_error'; The output should look something like this: +---------------+---------------------+ | Variable_name | Value | +---------------+---------------------+ | log_error | /var/log/mysqld.log | +---------------+--------...


10

Thank you, dawud, you pushed me in the right direction. What I had to do here is make radiusd.service start AFTER mariadb.service. I fired up vim at /etc/systemd/system/multi-user.target.wants/radiusd.service and added a line in [Unit] section: After=mariadb.service So it looks like this: [Unit] Description=FreeRADIUS high performance RADIUS server. ...


10

For units defined in static files you could use systemctl status, with the information outputed issuing that command, you will be able to see its location. For example: # systemctl status sshd ● sshd.service - OpenSSH Daemon Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled; vendor preset: disabled) Active: active (running) since Mon ...


10

Try yum remove mysql Then try service mariadb restart Then look at the out from service mariadb status You should see it running then the commands your tried early should work if yum remove mysql does not work Try chkconfig mysql off Reboot and try to start maria again.


9

I hope it will be helpful to you. try performance_schema = off in [mysqld] section of your configuration. https://mariadb.com/resources/blog/starting-mysql-on-low-memory-virtual-machines/


9

For a long-running session that's idle, like running mysql on the command-line, your timeout client and timeout server are much too short. They're probably fine for a web server hitting the DB cause the connection is only open for as long as it needs, and each page load creates a new connection. To allow the connections to stay open for 10 minutes, change ...


7

I've found I also need to grant SELECT on mysql.* to have mytop actually succeed, in addition to the usage, process referenced above.


7

You still have the MariaDB yum repository on your system. As long as you do so, MariaDB will continue to replace MySQL. To resolve the issue, remove the MariaDB repository. Do this by locating the file (it may be named something like mariadb.repo) in the /etc/yum.repos.d directory. Once you locate the file, you may remove it, or you may edit the file and ...


7

Configuration files in /usr/lib/systemd/system/ should not be edited by hand and it is perfectly normal (if not expected) that an rpm will update files that it manages in this directory on update. As @sickill and @Cherif KAOUA pointed out in comments [https://stackoverflow.com/questions/27849331/how-to-set-nginx-max-open-files/36423859#36423859] you should ...


7

The solution to the error in my case was that there was no [mysqld] section at all in the my.cnf config files. Adding this solved the issue: [mysqld] bind-address = :: Not sure why it was not added by default. Note that the reason to use :: over 0.0.0.0 is that :: works for IPv6 too (mentioned in mySQL manual, but not mariaDB manual). This also fixed the ...


7

Remove the mysqld.service symbolic link in /etc/systemd/system and enable the mysqld.service again: rm /etc/systemd/system/mysqld.service systemctl enable mysqld.service


7

While this might work without immediate problems, this is a very bad idea. Don't do this. MySQL expects to have full control over its data directories. Instead, if you have lost root access, schedule a maintenance window and reset the root password for MySQL and afterwards, drop the database properly.


6

I had a similar issue. Setting the environment variable DEBIAN_FRONTEND=noninteractive worked for me. So in your case, you need to run (as root) DEBIAN_FRONTEND=noninteractive apt-get install -y mariadb-server


6

the solution actually is simple. !includedir /etc/my.cnf.d is your last line on /etc/my.cnf, so mysql can't read complete '/etc/my.cnf.d' only '/etc/my.cnf.' You just need add one more line so mysql can read its. !includedir /etc/my.cnf.d # add new line here


6

You need to run mysql_install_db to initialize MySQL data directory.


6

With help from #debian-next I found out the problem was probably in the digitalocean custom kernel. Upon checking it turned out I was using a not very recent kernel – 3.2.0-4, but after selecting a more recent version from the web interface and rebooting it works OK.


5

Both platforms use the same mechanism for replication: Galera. On the page at that link, you'll notice there are images featuring both PXC and MariaDB Cluster. Galera library provides transactional replication. MyISAM doesn't do transactions, so the problems you may be having now are very likely related and would not be any different on the alternate ...


5

MySQL should use as much as free memory you have. The number of threads at this scale is very small and it doesn't affect the memory usage. The threads are sharing the same virtual memory space. They use only a few KB for thread metadata. The memory usage on the new MySQL is actually smaller than before. It has allocated in the virtual memory space 1.1GB, ...


5

Solved, the guilty was SELinux. [root@pw000i rafael]# getsebool -a | grep httpd httpd_anon_write --> off httpd_builtin_scripting --> on httpd_can_check_spam --> off httpd_can_connect_ftp --> off httpd_can_connect_ldap --> off httpd_can_connect_mythtv --> off httpd_can_connect_zabbix --> off httpd_can_network_connect --> off ...


5

An old question but this is no longer true. Here is a link to the CentOS 7 + MariaDB 10.0 repo config tool: https://downloads.mariadb.org/mariadb/repositories/#mirror=coreix&distro=CentOS&distro_release=centos7-amd64&version=10.0


Only top voted, non community-wiki answers of a minimum length are eligible