15

Running top in batch mode to report memory sizes periodically can be used to see who is using the memory when things go south. Runing sar in batch mode should give some good diagnostics on memory use, and related I/O. Running munin to monitor the system should give you a graph with good detail on what memory is being used for. This may help a lot. You ...


9

Your memory usage is fine. You have 1633 MB useable of 2003 MB (the free section in the second line, where buffers are considered), 1350 MB is used up by buffers. Please read this site for an explanation.


8

You have earned Confused by Linux memory usage badge! Processes are not the only thing eating up memory in Linux. The frequently used files and directory entries are cached in RAM - that's because reading the files from RAM is lots faster than reading them from disk. I bet you didn't take buffers and cached columns into account while calculating the RAM ...


8

To check top 20 largest consumer of physical memory (resident set size). crash> ps -G | sed 's/>//g' | sort -k 8,8 -n | awk '$8 ~ /[0-9]/{ $8 = $8/1024" MB"; print }' | tail -20 To check the number of hugepages. crash> p -d nr_huge_pages Update: A) crash dump was captured from following kernel version. $ crash --osrelease vmcore.flat  2.6.32-...


7

Don't worry! You might just be over-caching! The default Output Caching configuration in IIS enables both kernel-mode and user-mode caching. Kernel mode caching is managed by the native HTTP driver (aka http.sys), and is lightning fast, but can only serve content that is "public", since it needs to be able to respond to a cache hit before the request ...


6

This is actually a known feature of Windows XP/2003. I'm not sure if Windows 7/2008/R2 retained this behavior. The working set of an application is trimmed when its top-level window is minimized http://support.microsoft.com/kb/293215


6

You have a kernel memory leak. The nonpaged pool is 2.5GB. You can use poolmon to see which driver is causing the high usage. Install the Windows WDK, run poolmon, sort it via P after pool type so that non paged is on top and via B after bytes to see the tag which uses most memory. Now look which pooltag uses most memory as shown here: Now open a cmd ...


5

I started to write an answer to your question, and in looking up the syntax for the exact tools I've used in the past to do this, I came across this post: https://stackoverflow.com/questions/395569/measuring-memory-use-of-device-drivers-in-windows The second answer seems to be most closely associated with the two tools I had in mind, namely poolmon and ...


5

In case anyone else suffers this. We have just experienced the same issue. A memory leak in php5-fpm. The RAM is used up with every page request and eventually maxed out. Then the CPU goes into overdrive with the KSWAP process running the swap disk. the only thing that fixed, although not the ideal setup was to change our www.conf pool file pm = dynamic ...


5

I am running a box with 32GB of memory, and the standout difference is the DirectMap4k value; DirectMap4k: 493076 kB DirectMap2M: 7862272 kB DirectMap1G: 27262976 kB vs yours; DirectMap4k: 11182080 kB DirectMap2M: 4677632 kB It might be a starting point.. Googling suggests that this value might be affected by the allocation to a VPS ...


4

It is probably not a memory leak... Your Connector Thread Pool is of size 200 (default) and all 200 connections are in use, this shows you have 200 request that are not terminated... The rest of the logs are because you stop Tomcat with those 200 pending requests... So the question is why are your requests not responding ? You may make a threaddump to see ...


4

This is just a guess, but it's too long for a comment, so here goes. With virtual private servers, you get a "slice" of a real server. Rather than spending, say, $500 each on 24 small servers with 512MB ram etc, it's cheaper to buy (and operate) one $3500 server with 12GB RAM and two six-core hyperthreaded cpus. Here's the trick: that server might sell ...


4

smem helped me track the problem to the kernel, and I believe the NVIDIA drivers were the culprit. Things are looking good after upgrading to 367.35. References: https://devtalk.nvidia.com/default/topic/952317/huge-memory-leak-/ https://askubuntu.com/questions/731677/out-of-memory-issue


4

Your Tomcat is using 22GB of memory because your -Xmx (JVM Heap Size) value is absolutely massive. If possible, you should start by reducing this value to 2048, 4096 or 8192, depending on your application memory requirements and see what the sweet spot is.


3

You have enough memory. You would have problem with memory if your used memory rizes to max amount and buffers and cached will be very low, using of SWAP will rize then you probably will have problems with free RAM. From your post it's everything ok.... This is simple explanation what commited memory is: Committed_AS: An estimate of how much RAM you would ...


3

I'm not a SQL internals guru, but to my knowlege, SQL will use as much RAM as you've configured it to and that the OS will allow it to have. There's more cached than the DB its self, for example the execution plans http://msdn.microsoft.com/en-us/library/ms181055.aspx As a good rule of thumb your SQL memory should be configured in the following way: Take ...


3

You are probably being confused by memory caching, see http://www.linuxatemyram.com/. There is a python script available at http://www.pixelbeat.org/scripts/ps_mem.py that will give you a slightly more accurate view of global and per-app memory usage.


3

Use the display-name option as documented in mod_wsgi documentation to label the mod_wsgi daemon processes. That way you can see with 'ps' if the large processes are in fact the mod_wsgi daemon processes. http://code.google.com/p/modwsgi/wiki/ConfigurationDirectives#WSGIDaemonProcess If they are quite fat, then Apache or mod_wsgi isn't anything to do with ...


3

Can you run this command. ps -G | tail -n +2 | cut -b2- | gawk '{mem += $8} END {Print "total " mem/1048576 "GB"}' Also, kmem -z and kmem -f might help. However, see that the entire swap space is consumed. You must have got some OOM messages in the log command. Can you pastebin the OOM messages. I can see the mode and race condition too. On other note,...


3

There are many tools available to help you track down issues like this. Start with the performance monitor which is provided with your OS. You can set it up to take periodic snapshot of pretty much any metric you can think of, including individual memory usage per process. In your case, that's probably the best tool for identifying rogue processes. Also ...


3

Nonpaged pool is kernel memory which can't be paged out into the pagefile when Windows runs out of free physical memory. It is used by drivers to allocate memory which they need. Post some pictures of taskmgr, when you into the issue. If the usage is too large, use poolmon to find the causing driver of the leak.


3

You can use valgrind to find memory related issues: Usage: valgrind --tool=memcheck program_name (/sbin/docker or wharever the path to docker is) valgrind --leak-check=yes program_name Example: valgrind --leak-check=yes /sbin/httpd Check for lines containing definitely lost or probably lost to confirm that there is a memory leak.


3

The linux kernel has a so-called OOM Killer built-in. It is the "Out of memory killer". So when your box has exhausted its ram & swap, the kernel will start killing stuff to make the server accessible. You can tweak the priorities of processes, to determine the "likelihood" of a process being killed. Read more at this link, see section "Configuring ...


3

The memory leak (or just high memory usage) is almost always because of Wordpress. Wordpress is a well known memory and CPU hog, especially if you are using bad plugins and templates. You may try to disable all the plugins and templates one by one until you find which one is causing the high memory usage and replace it with another similar one or report ...


3

It looks like an infinite loop as line 159 of wp-admin/includes/file.php is a recursive call to the function wp_tmpnam(). It breaks the update process, so may be it could be worth checking this small correction, which describes your problem : wordpress bug fix


3

This is really more of a developer question, and is not related to IIS. First thing you should do is identify which generation heap the memory is in (0, 1, 2, or 3 (Large Object Heap)) Process Explorer provides an easy way to display this information. For the most part, the .NET GC is self-managing. There are a few .config parameters to adjust this,...


3

I'm surprised there aren't more reports like mine. That may be because this is normal, expected behavior... but this is not related in any way to AWS. This is the installed server OS, itself, doing scheduled daily maintenance/background jobs. You actually got really close before you stopped investigating. In the file /etc/crontab, you'll find this: ...


2

Here's two things to check: Most likely you have a memory leak. pm.max_requests will kill/restart the php-fpm child process after it's handled this many requests. Since it takes about a day for your box to slow to a crawl, try setting this to a number to causes each child process to be respawned every 20 minutes or so. So if you get 200 requests a minute, ...


2

This smells like a classic memory leak: On your next restart note the size of various programs, and then periodically re-check and see which ones are growing. If it IS a memory leak then ithout access to all the source code it's hard to pinpoint the problem. If it looks like it's your python app you can trace the Python code and look for the source, but the ...


2

I eventually found the reason why memory was being consumed so quickly during the automated build. By creating a dump of QTAgent.exe, we were able to examine its content to find what is on the .NET heap. It turns out that we were placing a large number of objects into a cache object, and since the cache object lives for the entire process, all of these ...


Only top voted, non community-wiki answers of a minimum length are eligible