Hot answers tagged

19

Enable and disable plugins on each node Graphs are added and removed via symlinks in the /etc/munin/plugins/ directory of the node. To remove a graph you must remove the symlink and restart the node: rm /etc/munin/plugins/diskstats service munin-node restart To add a graph you must add a symlink in the plugins directory to an executable. eg: ln -s /usr/...


14

Many perl modules will be available within the usual package hierarchy. For Ubuntu, I believe the package you want is called libdbd-pg-perl - so try installing that with: sudo apt install libdbd-pg-perl For packages not included within the package hierarchy, you can use the perl module CPAN to install them. As root, run perl -MCPAN -eshell and follow ...


11

The base tool used by Munin is rrdtool and this works by averaging down values for longer time periods. It records actual measured values eg. once every 5 minutes for a day (and then starts overwriting older values, hence "round robin"), and then derive an average of 12 of those values down to an one-hour resolution that it keeps for 30 days and maybe ...


9

There are two things you need to set for Munin to send out alerts. If both items are not set, mails will not be sent. This is how I have Munin configured to send e-mail via localhost on the machine Munin is running on. Please compare to what you have & adjust accordingly: contact.myalert.command mail -s "MUNIN - ${var:group} :: ${var:host}" mymail@...


7

So, I figured out the solution. I had to change my email setup in /etc/munin/munin.conf from: contacts me # may be unnecessary and cause warnings contact.me.command mail -s "Munin notification ${var:host}" myemail@gmail.com contact.me.always_send warning critical to: contacts me # may be unnecessary and cause warnings contact.me.command mailx -r ...


7

I solved this! Getting frustrated as heck about this issue, I ran a Munin module suggest command like this: sudo munin-node-configure --suggest In the piles of output here are the relevant Apache related lines: apache_accesses | yes | no [LWP::UserAgent not found] apache_processes | yes | no [LWP::UserAgent not found] ...


7

The df plugin in Debian also checks the dynamically mounted filesystems under /run/user/<uid> which appear when a user logs in and which disappear when the user logs out. Even though all levels are OK, this appearance and disappearance is considered a change which triggers an email. You should be able to avoid this by creating a file called /etc/munin/...


6

You have wrong fastcgi_pass parameter, it should pass requests to spawn-fcgi just as munin's wiki says not to php-fpm. For Ubuntu/Debian: sudo apt-get install spawn-fcgi spawn-fcgi -s /var/run/munin/fcgi-graph.sock -U www-data -u www-data -g www-data /usr/lib/munin/cgi/munin-cgi-graph And dont forget to fix nginx location and restart it afterwards: ...


5

I once had this problem when one of my servers restarted, runing the command munin-check helped me realize the problem had to do with folder permissions. Note: Even though I already had a folder /var/www/html/munin/web/monitoring and it has correct permissions set, munin-check complained about not finding that folder, I guess that's what the "this script ...


5

In my experience, these plugins are likely not working due to nginx misconfiguration. Here's a shortlist of what to do in this case: 1. Check nginx installation Nginx must be compiled with HttpStubStatusModule module. You can check that by running following command (under sudo or root): nginx -V 2>&1 | grep -o with-http_stub_status_module If you ...


5

I don't really use Munin but as I see an unknown_limit setting can be set for items/plugins which defines how many consecutive unsuccessful readings should occur before setting a value to "unknown". Based on the Munin::LimitsOld module it defaults to 3, I think you should try to set or increase this number. I have checked this on Munin 1.4.5.


4

As I am a long time Munin user, I can give you few quick thoughts on using it: using a SSH tunnel (is that illegal as well?) to get behind the firewall. The obvious port forward, you mentioned. If you have SSH of the monitored machines already exposed, you can use Munin's SSH support to get to those. You can use one very light-weight node behind firewall, ...


4

You don't say how you have munin reporting, which makes this difficult to answer. I'll assume you have it sending emails directly, with something like this in munin.conf: contact.dax.command mail -s "Munin notification" dax@example.com If this is so, the only way I know to silence a single alert is to tell munin that it's not a problem by raising the ...


4

The answer is that the munin-node package in Debian 10 includes /lib/systemd/system/munin-node.service, which sets ProtectHome=true. Debian 9's munin-node package does not have this file. Setting ProtectHome=read-only is one solution, or even ProtectHome=false to include write access. However the ProtectHome flag exists for good reasons. Arranging for ...


3

I wrote the plugin. Here is a script I use to dump out the contents of the store file. I'm also interested in knowing if the self discovery identified the correct interface for you. #!/usr/bin/perl use Storable; use Data::Dumper; my $file="/var/lib/munin-node/plugin-state/nobody/bandwidth_eth1.state"; my $dump; my $perf_ref; my $store_ref = retrieve($...


3

From the man page for iptables: every packet only passes through one of the three chains (except loopback traffic, which involves both INPUT and OUTPUT chains); In other words, loopback traffic does get caught by iptables, as you've now discovered... I'd suggest something like the following: -A INPUT -p tcp -m tcp -s 127.0.0.1 -d 127.0.0.1 --...


3

My reputation doesn't allow commenting, but correct env.connector is crucial for other plugins than tomcat_jvm. In my case I needed to drop quotation marks ("), i.e. env.connector jk-127.0.0.1-8009 If you can't find the correct connector name, try either $ lynx http://localhost:8080/manager/html or $ curl http://localhost:8080/manager/status?XML=true ...


3

To update charts I use : su - munin --shell=/bin/bash test -x /usr/bin/munin-cron && /usr/bin/munin-cron Probably not the solution, but worth trying ...


3

On Ubuntu 20.04 server problem was related to systemd. I solved that by changing (as a root user) /usr/sbin/munin-run file from: my $ignore_systemd_properties = 0; to: my $ignore_systemd_properties = 1; Or, as I found out, more proper solution is: to change /lib/systemd/system/munin-node.service file from: ProtectHome=true to: ProtectHome=false And then ...


3

Debugging You can debug the plugin by using the "munin-run" command, optionally with "--debug" and "--pidebug" parameters. Check for dependencies On a default installation, it will say: # /usr/sbin/munin-run --servicedir /usr/share/munin/plugins/ memcached_ autoconf no (Cache::Memcached not found) This perl library is found in the libcache-memcached-...


3

Did you check root's crontab ? Use crontab -l as root to get a listing of it. Failing that take a look in the usual places /etc/crontab /etc/cron.d /etc/cron.*


3

Really you're asking "Why does Munin report things in a strange way?" There are a number of reasons for this to happen. RRDtool (the component that creates the graphs you can see) is not meant to be a one-to-one mapping of value at a given time, it is a graphical representation of a round-robin database. These databases average out data and they are a "lossy"...


3

Make sure that /var/lib/munin/cgi-tmp/munin-cgi-graph/ is writable by web user/group. You can check with following command: ls -l /var/lib/munin/cgi-tmp/munin-cgi-graph/ As long as you are using CentOS and Apache, you should be able to fix it with following commands: chown -R munin:apache /var/lib/munin/cgi-tmp/munin-cgi-graph/ chmod g+w /var/lib/munin/...


3

Did you resolve this situation? I believe the issue is in the server2 configuration file. In this file, one finds the line: host_name server1.com This line should either be "server2" or commented out if the hostname returns the correct information. (from munin-node.conf): host_name: The hostname used by munin-node to present itself to the munin master. ...


3

You likely had a background job start around the time the nice % jumps. You can check out the current niceness of processes on the system with ps (i.e. ps -eo cmd,pid,nice, -e for showing all processes, -o for selecting attributes listed in man ps). top will also show you the niceness under the NI column.


3

It´s probably the diskstats_latency plugin, try the following: diskstats_latency.centos_home.avgwrwait.warning 0:15 diskstats_latency.centos_home.avgrdwait.warning 0:15 diskstats_latency.centos_swap.avgwrwait.warning 0:15 diskstats_latency.centos_swap.avgrdwait.warning 0:15 Please note that this is for both write (avgwrwait) and read (avgrdwait) latency. ...


2

If you do not use apt_all munin plugin you can just comment out this cron job in /etc/cron.d/munin-node


2

I noticed that not everything was removed from the installation so manually removed the munin web directory and also removed the munin user-name and group from the sever. Don't do that! Because you didn't purged properly the users stored in /etc/passwd file, which dpkg queries to compare with the statoverride file, do not match up and dpkg is throwing a ...


2

The only way I found to avoid this problem without modifying munin sources was to avoid using -a option with smartctl, e.g. use something like this in /etc/munin/plugin-conf.d/munin-node: [smart_sda] env.smartargs -H -i -c -A -l selftest -l selective (i.e. all options normally included in -a except for -l error).


2

k == kilo == 1,000 == 10e3 That means 1,750 reads/second and 920 writes/second were your maximum values. But that should also be clear from your graph... Looking at my graph below, you can see read maximum values of 1,753 very prominently...


Only top voted, non community-wiki answers of a minimum length are eligible