Hot answers tagged

4

I encountered the same problem after an upgrade, my systemd service started exiting with error code 0 every time it was started. This is due to a February update to react-scripts start.js Kolega's answer is really the best approach to resolve this: Set the CI (Continuous Integration) environment variable to true. This can be done in the service file with: ...


3

I solved this by adding the following to the [Service] section of my .service file: StandardInput=tty-force


3

You need to create a server block in nginx, or use an existing one, which contains a server_name matching the hostname you are trying to use. You have twice used hostnames that are not shown in the nginx configuration you posted, so you need to add them.


3

Most likely this could be nginx issue, did you restarted nginx after making changes to config? Just to make sure, you not using the same dns record as you using for first site which would be a CNAME record pointing to cloudfront. Update your nginx server block to include both the name (naked domain + your www as you trying to access using in the example you ...


3

This isn't a Route53 problem. So long as your request for a domain name is mapped to the correct IP then Route53 has done its job. You don't even need different ports, Server Name Indication (SNI) lets you have as many IPs as you like on the same IP for http or https. I suspect your issue is with your Nginx or downstream config. That config you pasted above ...


2

You cannot put new versions of a package into a repository, unless it is managed by you (which is not the case, especially for the standard repos). Often the official repositories only include newer versions of a package very late, if ever. (For example for stability reasons) But you can add other repositories to your system, so that yum can get the newer ...


2

Your CentOS is just too old. You can check which package the library belongs to by running yum provides /usr/lib64/libstdc++.so.6. In my case (on CentOS 7, but that doesn't matter for this) this is libstdc++-4.8.5-39.el7.x86_64. If you look up the package for libstdc++ for CentOS 6 on pkgs.com you'll see against which glibc headers it was compiled. In this ...


2

Mail deliver is done by the SMTP protocol. This is a hop-by-hop protocol which means that connections are at most encrypted between the hops (i.e. mail servers) and that each mail server in between can read (and change) the mail. What you see in the specific Received header are information about the connection from your companies mail server to Google's ...


1

If you want to have non-exiting service, with npm start you have to define a CI variable which prevents quitting after reading EOF. This solution can be run in users session as well. The important part from my service file is Environment=CI=True. [Unit] Description=Project [Service] ExecStart=/usr/bin/npm run start --prefix /home/ondrej/project Environment=...


1

The issue you encounter is with the ports not allowed by Firewall. Please set up the firewall setting to allow port 9999, make it open. If you're not able to do that ask a hosting support to help with it. What control panel do you use? Update:


1

You should put the site config files in /etc/nginx/sites-enabled. To solve your problem, check if you have a default site config in /etc/nginx/sites-enabled and delete it. Then, move your myapp.conf file to /etc/nginx/sites-enabled and restart nginx.


1

Have a look at this article: The TCP/IP port numbers below 1024 are special in that normal users are not allowed to run servers on them. This is a security feature, in that if you connect to a service on one of these ports you can be fairly sure that you have the real thing, and not a fake which some hacker has put up for you. To run Node.js application on ...


1

You should build the container in such a way that it works right after starting without executing extra commands. Maybe a tutorial on Dockerizing node.js apps may come handy for start. Hope that helps :)


1

By reviewing some resources I'd say that you might be affected by this issue, it seems to happen that the custom domains add significant latency when using App Engine. I found this article with some useful insights over the RTT behavior between regions/cloud providers, and it looks like the responses as you have pointed should be faster.


1

I have tried to create an App in GAE Flex in asia-east2, but every time I try with this location, it fails, but this is due to my organization restrictions. I have created the app and successfully deployed in the region asia-northeast1. Lets start narrowing down our issue: according to the GAE location documentation: Once you have chosen the location for ...


1

I think the solution should be a little architecture modification. As a PaaS, you don't have too much access to GAE to run some admin operations. Knowing this, these are the architecture changes I propose: Use a Virtual IP for the running database server and change between the servers on failover. The DNS will be mapped to the Virtual IP only. OR Verify ...


1

I fixed it by another method: # any url that is not served by a file is passed to nodejs location / { try_files $uri $uri.html $uri/ @backend; } # all other URLs are served dynamically by nodejs location @backend { proxy_pass http://localhost:3000; proxy_http_version 1.1; proxy_set_header ...


1

If you are using Express, the answer is here: https://stackoverflow.com/a/11911629 You did not provide enough information on your setup to give a more detailed answer.


1

I'm running a similar setup on Debian, and my service looks like this: ... [Service] Environment=NODE_PORT=3000 Type=simple User=www-data Restart=on-failure WorkingDirectory=/var/www/<your-code-directory> ExecStart=npm start ... Hope this helps!


1

yum module enable nodejs:12 yum install @nodejs:12/common Taken from here: https://docs.centos.org/en-US/8-docs/managing-userspace-components/assembly_installing-rhel-8-content/


1

Try the following location block: location /api/ { proxy_pass http://localhost:5000/; } Do not miss the trailing slash of the proxy_pass directive parameter! You can find description of this construction behavior here.


1

It looks like your NodeJS app is sending RST packet to nginx for some reason. You could try tcpdump and/or strace to capture network traffic and syscalls around the time the error happens; then investigate if there's something weird going on. This resource can be useful, which seems to describe a very similar issue, related to keepalive timeout: http://...


1

If you are sending your JWT in a header, then your assumption was right, you have to tell CloudFront to forward the header to the origin. It can be achieved by changing Cache Based on Selected Request Headers option in your cache behavior to one of these values: All. This will forward all headers to the origin; Whitelist. Then you can add your header name ...


1

You didn't give much information on how your Parse Server is setup, but in my opinion the easiest way to accomplish what you want is to have a reverse proxy sitting between the clients and your Parse Server. Like in this diagram: In this setup, your clients are in the leftmost side and they access your servers through the internet; your Parse Server (and ...


1

if you are using nvm node version manager, use this comment to create a symlink: sudo ln -s "$(which node)" /usr/bin/node


1

Why sites-enabled is included in your nginx.conf file twice? include /etc/nginx/sites-enabled/*; The above line is present in two places of the conf file: inside http block As the last line of the file, outside the http block May be the second one causes the problem as it will add the map directive from the app file outside the http block. If there is no ...


Only top voted, non community-wiki answers of a minimum length are eligible