Hot answers tagged

22

The nodejs package you installed from the PPA includes npm since v0.10.0. Since you have v0.10.15, when you ran sudo apt-get install nodejs you also installed npm. Try to run npm to confirm. Also see the offical installation guide (the one you followed is a copy of it, but the official one has a few extra details).


13

I just re-checked this. Both nodejs and npm and all dependencies for both have been added to epel 7. I just installed both on my CentOS 7 box. You should be able to do: yum -y install nodejs npm The -y flag will automatically answer "yes" to every confirmation question, so leave it out if you want to be able to say no to something.


9

On Centos 7, for installation of npm and nodejs, follow these steps 1. Open terminal 2. Run these commands (With sudo or root) yum install epel-release yum install npm nodejs


8

curl -L https://npmjs.org/install.sh | sh I found this here: https://www.npmjs.org/doc/README.html#fancy-install-unix- I tried it on a fresh CentOS 7 install and it works!


8

NPM isn't packaged for EPEL 7 yet. Give it some time, they are having to update thousands of packages already and had to wait for the CentOS release which was just a couple of days ago. I suggest contacting the package maintainer (who appears to be patches) as they may not be aware that CentOS 7 is released and that they can now build their packages for it.


7

Solution is npm install --no-optional


4

I ran into the same issue. It seems that for the latest version of grunt-docular to run the server you must run: grunt docularserver If doing that you run into an error of the type "path.join expects strings", you must add the following to your grunt config file: docularserver: { targetDir: "//path to where the docs are generated" }


4

I just ran up against the same problem and after some random kicks and punches, was able to get things working. Step 1: Remove Yeoman $ npm uninstall -g yo Step 2: Clear NPM Cache $ npm cache clean Step 3: Upgrade NPM to latest version $ npm install -g npm Step 4: Install Yeoman $ npm install -g yo After doing this, things kicked into life. I saw ...


4

I found Chris Siebenmann's article quite insightful: Why people keep creating new package managers It boils down to a conflict of perspectives/interests between the sysadmins/OS maintainers, who want a stable and uniform environment "in" their operating system, and programmers/languages, who want faster iterations and a uniform package management across ...


4

I encountered the same problem after an upgrade, my systemd service started exiting with error code 0 every time it was started. This is due to a February update to react-scripts start.js Kolega's answer is really the best approach to resolve this: Set the CI (Continuous Integration) environment variable to true. This can be done in the service file with: ...


3

This is probably because you have an env_reset directive in your sudoers(5) file. By default, the env_reset option is enabled. This causes commands to be executed with a new, minimal environment... That minimal environment does not contain a PATH. The Command Environment section of the sudoers(5) man pages has lots of relevant information for you to ...


3

Wa Alikom Al Salam Nasser =) If you have python2.7 in your $PATH and you can issue it directly from the command like '$ python 2.7', try putting it as an argument for --python: $ npm --python python2.7 install If it didn't work try using the full path to python2.7 $ npm --python /usr/bin/python2.7 install


3

If you don't have sudo installed, then your command string should be this instead: curl -sL https://deb.nodesource.com/setup_9.x | bash - apt-get install -y nodejs


3

I solved this by adding the following to the [Service] section of my .service file: StandardInput=tty-force


2

You have to first install npmbox module globally, This module creates an Offline package with all depedencies of given module. Then you could use npmunbox command to install that package to your offline machine. To install npmbox: npm install -g npmbox To create offline package of a module: npmbox -v localtunnel, It will generate a localtunnel.npmbox file ...


2

Okay, I have found solution in here: https://askubuntu.com/questions/269727/npm-errors-when-installing-packages-on-windows-share I just have to use npm install --no-bin-links. Would be glad to have an answer why.


2

It means : If "node_modules/phantomjs" is not directory, run "npm install -g phantomjs" See wikipedia true/false


2

I did it by adding /usr/local/share/npm/bin to my path. (via editing my .bashrc file) export PATH=/usr/local/bin:/usr/local/lib:/opt/local/bin:/opt/local/sbin:/usr/local/share/npm/bin:$PATH


2

Your CentOS is just too old. You can check which package the library belongs to by running yum provides /usr/lib64/libstdc++.so.6. In my case (on CentOS 7, but that doesn't matter for this) this is libstdc++-4.8.5-39.el7.x86_64. If you look up the package for libstdc++ for CentOS 6 on pkgs.com you'll see against which glibc headers it was compiled. In this ...


1

This is error thrown due to expiry of npm for Ubuntu 14.04 to get around quick fix add lines ADD package.json /opt/flask-app RUN npm config set strict-ssl false After these lines # copy our application code ADD flask-app /opt/flask-app WORKDIR /opt/flask-app


1

You need to set both ExecStart= and WorkingDirectory= to the appropriate values. For example: WorkingDirectory=/MIDDLE/uow/lets-chat ExecStart=/usr/local/bin/node /MIDDLE/uow/lets-chat/app.js


1

You will need to generate a keypair for your application to use. The private key gets deployed to your EB server, in whatever location your application needs, and the public key gets added to your list of deploy keys in Bitbucket.


1

Though this question is a little old, this was an issue with the NPM registry that affect 0.5% of all package tarballs. The error was born of a discrepancy between Nginx's ETags and the NPM CDN's use of cache headers. The outage began on the evening of July 1, 2016 and ended around 9:00 PDT on July 6 5 days laters. A full summary can be found on NPM's ...


1

I have changed Putty encoding to UTF-8 and the problem was solved.


1

The problem is not in the npm packages. It is the npm itself. The npm in Ubuntu repository is too old. Use this guide to install the latest one, and everything works.


1

Thanks to viq on the IRC channel, I was able to solve this problem. The solution is to change the $PATH variable of the minion /etc/init.d/salt-minion: Change this: PATH=/sbin:/usr/sbin:/bin:/usr/bin by PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/bin You may have to call service salt-minion restart on the minion.


1

You would get much better results using puppet modules for apt, nodejs etc. take a look at puppet forge. Using exec is a bad idea, as you really need to take care of the idempotency on your own. For example instead of lines: package { 'nodejs': ensure => latest, require => [Exec['apt_update'], Exec['add-node-repo']] } # Install npm exec { ...


1

I have make a copr repository which provide the latest (sync with the Fedora rawhide) NodeJs and NPM. It also contains the build dependencies should you want to rebuild it. Note that to build the latest NPM, you need openssl >=1.0.2, but EL7 only provide 1.0.1. So if you don't want to update the openssl to 1.0.2, please append exclude=openssl* to the end ...


1

Don't run the automation software as local system. Instead, create a new dedicated service account (admin level if needed). You can also make it so that this account can only log on from this system and not remotely. I'd would try running the software as non-admin first.


1

Are you used the right repository to install NPM? apt-add-repository ppa:chris-lea/node.js apt-get update apt-get install -y nodejs I used to install nodejs without this repository and got a lot of troubles, with this repository i can use NPM install free of errors in my Vagrant Virtual Box Using Ubuntu 12.04, try it.


Only top voted, non community-wiki answers of a minimum length are eligible