3

Same issue. It seems /home/influxdb folder is needed with the right permissions. Following worked for me sudo mkdir /home/influxdb sudo chown -R influxdb:influxdb /home/influxdb Alternatively modifying the useradd command to following might also work (I haven't tried it) and this would be a cleaner fix: sudo useradd -d /home/influxdb -rs /bin/false influxdb


2

Regardless of what you try, you're going to have to create a bootable Ubuntu USB. Once you have the bootable USB, boot from it, and then you can either try to painstakingly change all of the permissions (do not recommend), or backup all of your data and reinstall the system. Remember that you will have to locate your hard disk and mount it before doing ...


2

I was having the same problem with /var/run/lighttpd set owned by www-data by something instead of lighttpd user. I added it to www-data group but apparently things still don't work sometimes, so I overrided the systemd service script with systemctl edit lighttpd: /etc/systemd/system/lighttpd.service.d/override.conf ----------------------------------------- [...


2

So, you'll need to be using a filesystem that supports User and Group ACL's (ext4 and xfs both do; but ext4 needs to be mounted with "acl" option set - "mount -o defaults,acl", for example) Then you just need to set the default facl to include full permissions for your user and r/x for everyone else. Say the directory the files need to be in is called /...


2

First, it's a bad idea to have files executable, so a better solution should be to do folders 755 and files 644 (or 640) find /var/www/ -type d -exec chmod 755 {} \; find /var/www/ -type f -exec chmod 644 {} \; Now, to ensure files are uploaded with specific permissions, checkout umask https://docs.oracle.com/cd/E19683-01/817-3814/userconcept-95347/index....


2

Found the problem. For reasons beyond my understanding at the moment, even though UAC slider was at the very bottom, there is a registry entry tied to UAC that was still set to 1. It should be set to 0. https://docs.microsoft.com/en-us/openspecs/windows_protocols/ms-gpsb/958053ae-5397-4f96-977f-b7700ee461ec?redirectedfrom=MSDN Open the Windows Registry and ...


2

What worked for me was giving permission recursively to aws-cli folder sudo chmod -R 755 /usr/local/aws-cli


2

The + at the end of the permissions string indicates that the directory has an Access Control List (ACL) applied to it. It is likely that your ACL is somehow denying the user sftpuser write access to the directory. To view the ACL for the html directory, use the command: getfacl html This should output something like the following: # file: html # owner: ...


1

As Halfgaar says it is probably a permissions problem. I have found that files belonging to root tend to accumulate in my git repositories, albeit very slowly. In my case they often seem to be in .git/objects and don't seem to cause problems there. However, if a lock file ends up belonging to root that is obviously going to be an issue. You can check ...


1

Install the binary properly in /usr/bin, as it should have been installed, and try again. The systemd unit does a lot of confining of the service, and one thing that is denied is access to user home directories. It's not expected that it will need to access a user home directory when running as a system service.


1

ssh requires the user used to login to server to have access to /home/username/.ssh. If you can't access the server with another user you can stop the instance launch a new instance with the EBS from the server attached to it login to the new server and adjust the permissions for on the EBS Consult this Q&A for the permissions you should have for the ....


1

I think to remove the file a12E3vdklK8KKdn you will need write access to the directory containing it. The file is being unlinked from the directory. The directory intermediate only has r-x permission for the autoagent group.


1

Is it possible that you forgot to restart grafana after the configuration change? If not, it's still using SQLite, which would explain why it's still working.


1

You have an extra statement in there (the top one) that allows "*" to access the bucket's objects. You only need the bottom policy to allow CloudFront to access the objects using an OAI. When you "block all public access", it sees that you have a public entry in there and it might just disable the whole policy instead of just the top part. Remove the first ...


1

folder where anyboody can write here , (subfolder and file) You can set the main folder's permissions: chmod 0777 but other users cannot access it unless the same permissions exist all the way to the root directory - not a good security measure in home directories. In addition SELinux permissions may cause problems with users writing outside their home ...


1

Windows 10 64-bit How to solve error messages: 500 Internal Server Error SoftException in Application.cpp:267: File “/home/username/public_html/mantis/index.php” is writeable by group How to change file / folder permissions with Cpanel or Filezilla for MantisBT or any file / folder. Your paths might be different. Remove write access for Group for ...


1

With Apache 2.4, Order allow,deny Allow from all Should be replaced by Require all granted Check your php.ini, if open_basedir has not been set to /var/www/html/... ; open_basedir, if set, limits all file operations to the defined directory ; and below. This directive makes most sense if used in a per-directory ; or per-virtualhost web server ...


1

I cannot get past the builtin\users group. If I remove or deny it, nobody can access the folder any longer. Naturally. Remove that and add the users or groups that should have access. Don't (in most cases) use Deny permissions.


1

Not an answer but FYI: when it says -bash: /bin/ls: Permission denied that means /bin/ls is the (program) file on which permission was denied -- which could be at any level of its path, and you have identified the problem was actually on / (only). -bash: means the error message is from your login (top-level) bash process; it does not mean any file -bash or /-...


1

I have resolved the issue. I rebooted linux into recovery mode. I selected extra options. I dropped into superuser mode i changed the permission of / back to 755 rebooted - works


1

If you are using a cloud storage device, like WD Cloud, instead of a domain related server, all you have to do is make sure to match the SAME username AND password on both systems. That is, create a LOCAL user, like "BackupUser" with a password, set that as the login user for the Cobian service, then go to the cloud device and configure the SAME ...


1

Even if you use PerfMon to collect data on each server I would really recommend using another tool for the actual monitoring. In addition to the (rather expensive) tools mentioned by Guido van Brakel in his answer, there are powerful free and/or open source tools like Zabbix and Grafana that can be used at little or no cost. I would also recommend looking ...


1

I've read many posts and answers looking for a solution to this issue. Users were uploading files to my vsftpd server but the permissions were not being set correctly. Specifically I wanted files to be created with a chmod of 664. To enable this I tried setting the vsftpd.conf local_umask to 0002. It did not work. The group permissions were not set to ...


1

You really shouldn't set 777, it would probably be better to just change the ownership of that directory to the www account. Anyway your changes in the Dockerfile really don't matter, because you have a volume (appdata:/var/www) meaning that the permissions you have in the image are masked by your volume. Your docker exec -it myapp /bin/sh would be failing ...


1

Windows Explorer has many problems dealing with a deep nested directory layout, especially when changing owner/ACL. I strongly suggest using SetACL Studio or the relative command line program SetACL. They are both free utilities which do their job. Compared to them, CACLS, ICACLS, takeown and the likes seem relatively primitive tools.


1

Stephen Ostermiller's answer solves the problem. Another way to do it would be: systemctl edit tomcat9.service put in [Service] ReadWritePaths=/var/log/ This will get written to /etc/systemd/system/tomcat9.service.d/override.conf. Then do systemctl daemon-reload systemctl restart tomcat9.service You can go back to the original with systemctl revert ...


1

When MQ Explorer has compatibility mode selected, the password is limited to 12 characters. If you do not have compatibility mode selected MQ will use a MQCSP structure to send the password and you can send a password as long as 256 characters. Some references are below. IBM MQ 9.1.0 Knowledge Center page Securing>Security overview>IBM MQ security ...


1

You can not mount ntfs so that permissions are disabled, I suppose (I am even in doubt that this was possible in Win XP). But you can bypass file permissions as Administrator, or any other account possessing backup privilege. You can even mount ntfs volume readonly (to be sure you did not accidentally change anything on the volume while you copied files) and ...


1

Some complicated commands don't work in sudoers files, or at least I've never succeeded. For something complex, I put the command in a shell script and allow that in the sudoers file. This way I'm less likely to get something obscure wrong with sudo syntax (which can lead to exploits) and the next admin can figure out what's going on quickly (perhaps ...


1

As mentioned in the comments, there is no granular capability to be used with --add-cap, so you will have to run the container in privileged mode using --privileged in order to get rid of that warning.


Only top voted, non community-wiki answers of a minimum length are eligible