3 votes
Accepted

Can't Install mcrypt for CentOS 7 Using php-common-5.4.16

You're running CentOS 7, but you installed EPEL for CentOS 6. This obviously is not going to work. Remove it and reinstall EPEL for CentOS 7. yum reinstall epel-release
user avatar
2 votes

Trying to install php-mcrypt

You installed PHP from the remi repository, but you disabled the repository. So yum can't install additional packages from it. To resolve the problem, re-enable the remi repository. yum-config-...
user avatar
2 votes
Accepted

How to install mcrypt in dual PHP version CentOS 6?

I used rpm2cpio to convert the only suitable .rpm file I found into a cpio archive on standard out. $ rpm2cpio php-mcrypt-5.4.16-1.el6.x86_64.rpm | cpio -idmv I then copied mcrypt.so an mcrypt.ini ...
user avatar
  • 1,717
2 votes

php-mcrypt package missing from yum on AWS AMI

I was able to install php-mcrypt following the suggestion on this page using EPEL for EL 7 into AWS release 2.0 (2017.12) Linux. This is an Amazon instance running Amazon Linux 2 (2017.12) which I ...
user avatar
  • 10.8k
1 vote

php-mcrypt (remi) error while upgrading from php 5.4 to 5.6 on CentOS 7

You installed PHP from the remi-php56 repository, but you have disabled that repository. Enable it and try again. Also note that your PHP application should not be using php-mcrypt at all.
user avatar
1 vote

linux - error while trying to install mcrypt extension centos 7

Your base PHP install appears to be from from Webtatic. The corresponding mcrypt package is called php70w-mcrypt: yum install php70w-mcrypt
user avatar
  • 96.6k
1 vote

How to install mcrypt in dual PHP version CentOS 6?

Unfortunately, the CentOS SCL collection for php54 does not include php54-mcrypt. You can take the SRPM for the php-mcrypt-5.4 and modify the spec to change the package name, install location, etc. ...
user avatar
1 vote
Accepted

install php-mcrypt Centos 6

Yes, it's unable to install that because it depends on PHP versions from the stock repos, while you've installed PHP from a third-party repo. Since you've stepped away from using the supported ...
user avatar

Only top scored, non community-wiki answers of a minimum length are eligible