Hot answers tagged

4

If you use Network Level Authentication in conjunction with RDP (which you should because it's the more secure option,) then you cannot connect if your password is expired. This means that you cannot connect in order to change your password because you cannot connect with an expired password. This is considered by design because there is no such feature in ...


2

According to the listed authoritative servers for abacushub.io, the specified subdomain does not actually exist: % dig +norec @ns3.iwantmyname.net. ifodgw.abacushub.io ; <<>> DiG 9.8.3-P1 <<>> +norec @ns3.iwantmyname.net. ifodgw.abacushub.io ; (2 servers found) ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- ...


2

You may be using TLS 1.0. Try this first: [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12


2

After reading much documentation found out what I had done wrong. I had broken everything by manually adding the new Cert to IIS myself on the RDWeb server. No idea why this broke everything. The correct method apparently is to just add the Certificate to the Deployment Configuration via Server Manager (to each of RDWeb, Gateway, Broker etc) and this auto-...


1

To prevent this from happening you MUST use Internet Explorer as your web browser, and you have to enable the RDS ActiveX control when prompted after visiting the remote web access site for the first time. If you want to avoid the Remote App web site, see here for some other ideas for deploying remote app for your users: https://www.concurrency.com/blog/w/...


1

This appears to be persisting. ProTip Kids: make notes! Set-RDSessionCollectionConfiguration –CollectionName <your collection> -CustomRdpProperty “use redirection server name:i:1 `n alternate full address:s:RDS01.corp.contoso.com”


1

I had this issue, it's all down to names and certificates. You need to ensure that: All servers are configured to present your External DNS name, RD Web Server, Session Hosts, brokers and Gateway (if you have one) Servers need to be able to respond to that External name on the internal network, so you will need to setup a second DNS zone on your Internal ...


1

Found this page after experiencing the same problem. For us the solution was to add port 3389 to loopback (aka Hairpin NAT) on our firewall. Some additional detail: Replacing the certificate was trickier than installing it the first time, but I think we did it correctly, and apps worked fine for a day or two. Users started getting errors on launch, and ...


1

It turned out to be a lot simpler than I thought. Simply using and publishing "logoff.exe" under sys32 does the exact same job without the complexity of permissions.


1

Couldn't you add this to the task scheduler with elevated privileges and then execute it when needed? Use an event id that is triggered when the user disconnects from Term services to run your script. That should execute after they disconnect and because you can provide admin credentials to the task, it should run without triggering a UAC prompt.. Not sure ...


Only top voted, non community-wiki answers of a minimum length are eligible