New answers tagged

1

I download and built the 5.8 sources, and did some testing, and to cut a long story short, all you need to do is change from using double-quotes to single-quotes for your string constants in RainerScript. I.e. try if $fromhost-ip=='192.168.0.50' and $syslogseverity<=4 then ... For other readers who may need to do a similar build, I downloaded the 5.8 ...


0

You should copy the key, the certificate and the root certificate chain. ALso you need to install rsyslog-gnutls. Then add the lines in the config (something like): $DefaultNetstreamDriver gtls $DefaultNetstreamDriverCAFile /etc/rsyslog-keys/ca.pem $DefaultNetstreamDriverCertFile /etc/rsyslog-keys/node3-cert.pem $DefaultNetstreamDriverKeyFile /etc/rsyslog-...


-1

Upon further troubleshooting, I found that selinux was enabled in enforcing mode which led to block rsyslog to send logs. Changed selinux mode to permissive, reboot the server and it started working.


1

Your rsyslog configuration specifies to log to a file or device that does not exist and cannot be created. Did you make a typo when you edited your configuration? You can find out which path is being referred to with a command like: [root@localhost ~]# rsyslogd -dn 2>/dev/null | grep "ACTION 8"


Top 50 recent answers are included