Hot answers tagged

25

curl (if compiled with HTTP/2 support) exhibits the same problem but shows the reason: http2 error: Invalid HTTP header field was received: frame type: 1, stream: 1, name: [upgrade], value: [h2,h2c] It looks like your server is offering an upgrade to HTTP/2 even though the connection is already done with HTTP/2 - which makes no sense. Not only that, it is ...


5

The question is old, but it will be found during searching. I spent some time to find solution to the same problem. Thus I decide to write the answer to share my results with others. Short answer: you should not use IIS Crypto to specify the order of Cipher Suites. I recommend you to click on "Defaults" buttons to remove previously set order and ...


3

I think this is a Safari issue rather than an AWS / SSL issue. The search for that error gets many, many results on Google. Everything checks out with the website according to the SSL Shopper test and SSL Labs Test. I found this possible solution to the problem. The solution was to go into Safari Preferences, under Privacy and list all Details. This ...


3

This could be related to the ssl session cache issue that is described in this ticket for nginx, http://trac.nginx.org/nginx/ticket/235.


2

In the intervening 3.5 years since this question was asked, I presume you found an answer. But if you didn't, this is what I do on my iPad and iPhone (screenshots from my iPhone since it's what I had handy as I sat in the airport). Go to Settings, Wi-Fi Then tap the (i) button on the appropriate SSID Scroll down and turn on Manual under HTTP PROXY, where ...


2

... "62.2.114.180", "227 Entering Passive Mode (172,30,0,248,228,14). It looks like that your server has a private IP but your client a public IP. From that I assume that your server is inside some local network behind a router which will forward most of the ports to the server so that FTP data connections work (at least 58300..58500, which are ...


2

This doesn't seem to be a problem with SSL (or Let's encrypt). The fact, that the request shows up in your log file proves that the request came through fine (the SSL handshake is done before the actual request reaches the server). A little googling for nginx http 499 shows that nginx uses this (unofficial) return code to indicate that the client closed the ...


1

I found a temporary solution to my problem. I just moved the server to a different hosting/datacenter! Update: Actually the problem reappeared again after few months... I really don't know what technical issue is causing the problem or how to fix it. Update 2: I talked to an IT networking expert and they told me the issue actually relies in government ...


1

Since you doubt the proxy in-between you and the website, can you bypass it by using the -L option in ssh? It will provide a secure tunnel between you and your website that cannot be altered by the proxy. For example, execute this on your desktop: ssh -L 2222:127.0.0.1:443 user@mywebsite.com Once this command has logged into your server, fire up the ...


1

Use SSL Labs to check your SSL: https://www.ssllabs.com/ssltest/ At the end of the report it will tell you which browsers it works on and which it does not. According to this question the problem may be in the Cipher used. The SSL Labs report shows which Ciphers you use, showing which ones are out of date. A good tool for generating an SSL configuration ...


1

Now facing the same/similar issue on iOS 12 with nginx 1.16.0 proxying to apache enabled with http2. Workaround is to disable http2 on nginx, the right solution is described here https://trac.nginx.org/nginx/ticket/915 or https://trac.nginx.org/nginx/ticket/1150 - adding proxy_hide_header Upgrade; will solve that. With Upgrade header (probably only) the iOS ...


1

Are you sure that it's Tomcat that's not working? It could be that the web browser is incorrectly reporting content size rather than transfer size. Check it with another web browser, or check the web server access logs. Note - confirmed as per comments above.


1

My issue was specific. XenForo features automatic gzip as an application-level config option. If you are having this issue, make sure that your application does not also gzip before it reaches your server. https://xenforo.com/help/config-php-options/


1

Workaround is to use the same session cache for all server blocks, e.g. to configure it on the http{} level.


1

I had this issue with a Windows Server 2008 R2 Datacenter IIS. The solution to my problem was to: Open up your server remotely Start your IIS manager Under the left Connections panel look for the domain that is giving you the problem with the SSL After locating and selecting it click on SSL Settings Under Client certificates choose Ignore Click Apply Under ...


Only top voted, non community-wiki answers of a minimum length are eligible