New answers tagged

0

I had this problem under Windows 10 Server with Apache 2.4 installation. Problem ist that there's only one port-binding allowed. The default httpd.conf has at the end the following section: <IfModule ssl_module> Listen 443 Include conf/extra/httpd-ssl.conf Include conf/extra/httpd-ahssl.conf SSLRandomSeed startup builtin SSLRandomSeed connect ...


0

why not just deny all server { listen 80 default_server; server_name _; location / { deny all; } }


0

For posterity, I discovered mod_macro. It gets rid of a lot of duplication by letting me write a Macro template for the blocks above and reducing my actual VirtualHost files to a single Use line with variables. Look for examples in the Apache docs.


1

For Windows: try WinSCP, it support that Feature since a while. I don't know any other client that implemts that feature. I assume it's just that FTP(S) is quite out of scope nowadays as implementation of that feature should be mor or less a no-brainer in most applications.


0

ERR_NAME_NOT_RESOLVED is a DNS resolution error and suggests the request is not even reaching your server. In addition to the config presented in your question, you would also need the appropriate A record (or CNAME record if these are the same domain, with just a difference in subdomain) defined in the DNS that points www.example.com to your server. ...


0

it's listed under /etc/apache2/sites-available, I have not included it anywhere, apache2.conf includes them by default it seems since I see IncludeOptional sites-enabled/*.conf in there "sites-enabled" is not "sites-available"? But ideally this should also be inside a <VirtualHost> container.


0

First, VirtualHost is an Apache term. NGINX does not have Virtual hosts, it has Server Blocks You will want to create a server block for each of your sites, each of them using the IP you wish to assign to the site. Your configuration would look something like this: server { listen 12.34.56.78:80; server_name 12.34.56.78; location / { ...


0

I'd suggest reading through the Grafana documentation. While the problem of proxying to different backends based on path isn't new, it somewhat died with the introduction of SNI and virtual hosts which eliminated the need for a 1-1 relation between IP and domain. While you don't have a DNS, you can still use domains by adding them to your /etc/hosts. Your ...


0

you may create an empty webpage(index.php) under your desired virtualhost directory and redirect to any other address you want to. just need to put the line below in your index.php, and modify the destination address. following is the PHP code for this purpose. < ?php header("Location: http://www.redirect.to.url.com/"); ?>


0

The common way is to use an Alias with an absolute path and a <Directory/> directive with the same path like this: <VirtualHost *:80> ServerName <url> ServerAdmin <email> DocumentRoot /var/www/html Alias /nextcloud/ /var/www/nextcloud <Directory /var/www/nextcloud> # --> enable stuff if needed, ...


0

Have you done a chown www-data:www-data -R /var/www/nextcloud to give apache2 ownership on the files?


3

There is no reliable way to determine whether a virtual machine's backing store is based on SSD or not. The hypervisor presents a completely virtual disk device to the virtual machine, and no attributes of the physical storage hardware are exposed. It might be local hard drives, local SSD, or remote storage, but this information is not given to the virtual ...


3

Sometimes, browsers will complain when your HTTPS website has assets that are called using plain HTTP to the same domain because of the mixed content problem, and the reason is pretty simple: if your website is using an available HTTPS connection, why would anybody be using a plain HTTP one? So, some good practice is calling your assets (JavaScript, images, ...


1

I have solved the problem. It was an image that was being called with http: instead of https: in my website styles.


0

Just in case someone else stumbles on to a similar problem, IN MY CASE it was the issue of some zombie apache processess that would not terminate when restarting apache. Those processess would still carry old vhost config and this is what was causing the issue. How to test/solve this? Crude solution and I guess someone may have a better one: Stop apache ...


0

I'm not sure if this is the "right" solution, but it worked for me. In the end, all I did was add a line to /etc/hosts on the "broken" client that could not connect to the server. I put the internal IP address (which I have my router set up to keep the same for all of my main devices, including my server) followed by a space separated list of the domains ...


2

<VirtualHost *:443> ServerName demo.website.com ServerAlias website.com <Location /api/socket> ProxyPass ws://localhost:5000/api/socket ProxyPassReverse ws://localhost:5000/api/socket </Location> <Location /> ProxyPass http://localhost:5000/ ProxyPassReverse http://...


3

As @MichaelHampton already commented: remove the following settings immediately: <Proxy *> order allow,deny deny from 193.37.XXX.XX allow from all </Proxy> Those are not needed for a reverse proxy but instead used to configure a forward proxy , open to almost anybody, which will allow your server to be abused. ( Fortunately you ...


0

Have a look into this folder: /var/www/apps/staging/example and be sure to remove the index.html Then you can simplify the proxypass as following: ProxyPass / http://localhost:4204/ ProxyPassReverse / http://localhost:4204/


Top 50 recent answers are included