14

From your Fiddler trace it appears that you're serving your pages using the built-in Visual Studio web server: Server: ASP.NET Development Server/10.0.0.0 If this was being served by IIS7 then we'd see: Server: Microsoft-IIS/7.5 The built-in Visual Studio web server only has a limited set of mime-types it can serve and has no knowledge of mime types you ...


7

The correct setting Microsoft added for what you need is AppLocker by GPO. You can add policy by filehash, filepublisher or path. With the filehash, it's harder for an user to bypass it, unless he get another version, but you could block the publisher too.


5

First, if you haven't already, check out Microsoft's free hosted TFS solution. That's probably the simplest way to go. If you still want to deploy TFS locally, you certainly can. If you have access to TFS (via a MSDN subscription, for example), it should just be a matter of downloading and running the installer. Verify that you're on a supported OS (Vista, ...


3

UPgrade the VM to 64 bit and give it 8+ gigabyte RAM and at least 2 cores - 5 are better. Sorry, but (a) Visual Studio uses multiple cores during compile etc. and (b) 4gb are not enough when debugging etc, I regularly take my dev envvironment over the 6gb limit. If the screen is super slow make it faster. How do you connect? Remote Desktop - that SHOULD ...


2

I've used Kev answer, by: Installing IIS 8.0 Express from Web Platform Installer Changing project's properties to use IIS Express and creating Virtual Directory for it Adding in web.config's configuration → system.webServer <staticContent> <remove fileExtension=".svg" /> <mimeMap fileExtension=".svg" mimeType="image/svg+xml" /> &...


2

As mentioned above, Cassini ignores these settings in web.config so one has to use IIS Express instead (at VS project settings) https://stackoverflow.com/questions/5924647/setting-mime-types-using-the-asp-net-development-server To get more info on how to configure MIME types using the admin UI or using web.config for IIS or IIS Express see: http://...


2

I've never run into that problem, but if you stop the application pool that the app is running prior to redeployment then that should ensure IIS is not locking the files.


2

My workaround for this was to create my own httphandler locally which overwrote the content-type for svg. public class SvgHandler : IHttpHandler { public bool IsReusable { get { return false; } } public void ProcessRequest(HttpContext context) { context.Response.ContentType = "image/svg+xml"; context.Response....


2

Have you verified you're not using a 32-bit driver on a 64-bit OS? http://support.microsoft.com/kb/942976 32 = C:\Windows\SysWOW64\odbcad32.exe   64 = C:\Windows\System32\odbcad32.exe


2

Uhh... Start Control Panel Programs and Features Turn Windows Services On or Off Uncheck Internet Information Services Click Ok Am I missing something?


2

There's a hotfix targetted at a similar sounding problem: Consider the following scenario: You have a computer that has the Microsoft .NET Framework 3.5 installed. You use Remote Desktop Protocol (RDP) to remotely access the computer. You try to run a .NET Framework 3.5-based Windows Presentation Foundation (WPF) application on the ...


2

Ensure you have the .NET Framework 3.5 installed via Control Panel > Programs and Features Ensure your IIS Application Pool is configured to use the .NET 2.0 CLR (IIS Manager > Application Pools > (Your pool) > Basic Settings Run aspnet_regiis.exe (see https://msdn.microsoft.com/en-us/library/k6h9cz8h.aspx for a complete reference) to ensure it is registered ...


2

First off, I hope your terminal server is a virtual machine. Before you continue, make sure you have a clean snapshot of the VM. One of your students will take advantage of the ability to run arbitrary applications and screw up your server. You should revert to the snapshot periodically, and always revert immediately before applying patches or installing or ...


1

Check the bindings on the new website. Is it bound to port 80? If you re-enable the default website can you browse it?


1

I also had this question posted on the MySQL forum. Here is the response I received: You're correct about that Connector/Net doesn't have to be in the GAC in order to work with Medium Trust, but this has some limitations. For the case of Entity Framework our driver needs Reflection, as you mention it, in order to be registered as a provider. Thus it can't ...


1

Make the service account for TFS a farm admin in SharePoint. If your service account is network service, use the name of the tfs server with the $ symbol. For example, domain\tfsserver$ Good luck!


1

You need Change and Read permissions. http://msdn.microsoft.com/en-us/library/bb778394 The real trick is assigning these permissions to the right account. If you used Network Service as the service account for Team build and the network share is on the same computer as the build service, you can just use "Network Service," assign Change and Read, and it'...


1

Ok well I found the problem...by default MS puts the MySQL db and table name in quotes. I remove the quotes and I can finally map the tables together. Yet another problem though...for another post.


1

It looks like what you are trying to do is have a dev server federated with adfs from domain 1 and then have the adfs from domain1 to accept tokens from adfs in domain2 using a claims provider trust. This way, users from domain1 and domain2 will be able to logon and access the dev server's app provided the claims rules are configured correctly. So the ...


1

If your machine is slow it could be because there is something wrong or it could be because there are 40 other VMs on there using all the resources. Without looking at the physical server and the vmware UI you simply can not tell what the bottleneck is. Inside the VM the CPU usage and IO stats are near meaningless because they are against a sliding scale ...


1

A virtual machine is just that, it's a fake machine running on another machine. Anything you can do to a physical machine, you can do to a virtual machine. Does this work on a physical machine? If so, it should be possible on a virtual one.


1

I am running IIS7, and was able to fix this by right-clicking on the server in IIS and choosing properties. Then I clicked on the MIME Types... button. I then clicked New. For the extension I typed in .svg. For the MIME Type I typed in image/svg+xml. I then saved is all and did an iisreset from the command prompt. Worked great.


1

There's another possibility answer for why this error might occur (in the general case), you could be running Express Edition, and your TFS database has reached the maximum database size for the license.


Only top voted, non community-wiki answers of a minimum length are eligible