Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
76

Worked out these steps which fix the issue for me: Open IIS Manager Click the server name in the tree on the left Right hand pane, Management section, double click Configuration Editor At the top, choose the section system.webServer/security/authentication/anonymousAuthentication Right hand pane, click Unlock Section At the top, choose the section system....


13

This solved my error on Windows Server 2012, IIS 8.5. Should work for other versions too. Go to Server Manager, click add Roles and Features In the roles section choose: Web Server Under Security sub-section choose everything (I excluded digest, IP restrictions and URL authorization as we don't use them) Under Application Development choose .NET ...


13

Found the answer after 4.5 hours of Googling! http://runtingsproper.blogspot.co.uk/2010/04/solved-breaking-parent-webconfig.html Basically taking advantage of <location path="." inheritInChildApplications="false"> <system.webServer> <!-- ... --> </system.webServer> </location>


9

The reason is that you have two web sites targeted on the same physical folder. And there exists an inheritance in web.config. http://vmsomething is the parent and http://vmsomething/my_application_virtdir is its child. The child web.config inherits all elements from its parent. And the web.config usually is not designed to work in such scenario. You can ...


6

I recently ran into this problem, in a similar situation. But the answer from rjenkins would seem to cause problems with virtual applications that relied on inheritance of parent settings. If you know the name of the rewrite rule you can just do this: <rewrite> <rules> <remove name="RewriteNameToDisable" /> </rules> </...


5

For future reference, this was the solution: <location path="wp-admin"> <system.webServer> <security> <ipSecurity allowUnlisted="false"> <clear/> <add ipAddress="ipaddr" allowed="true" /> </ipSecurity> </security> </system.webServer> &...


5

For the appSettings and connectionStrings nodes in web.config you can move these into separate files outside of web.config. In your web.config you would have: <appSettings configSource="appsettings.config"></appSettings> and then a new file appsettings.config: <?xml version="1.0"?> <appSettings> <add key="foo" value="bar"...


5

i think this can solve your problem. place this web.config in directory that contain target directory : <configuration> <system.webServer> <security> <requestFiltering> <hiddenSegments> <add segment="target directory name"/> </hiddenSegments> </requestFiltering> </security> </...


5

You need to use the httpErrors element for IIS 7. <configuration> <system.webServer> <httpErrors errorMode="DetailedLocalOnly" /> </system.webServer> </configuration> http://www.iis.net/ConfigReference/system.webServer/httpErrors


5

Configuration locking can happen at: Applicationhost.config (config string: MACHINE/WEBROOT/APPHOST) a Site Web.config file (MACHINE/WEBROOT/APPHOST/Web Site Name) Any App web.config file that (MACHINE/WEBROOT/APPHOST/Site Name/App Name) Locking a section (section: IIS configuration section, eg <asp>) lets you deny the ability to configure those ...


4

It appears the Brotli module you referenced requires a paid license, so I haven't tried it, but I encountered a similar issue with my own open source Brotli plugin for IIS. Current browsers advertise Brotli support after gzip and deflate in the Accept-Encoding header. Typical headers will look like: Accept-Encoding: gzip, deflate, br. The HTTP RFC gives ...


3

If you suspect that the web.config file includes a custom header, why don't you have a look? :-) Open the web.config file in your favorite XML editor (I prefer notepad++), locate the following section: system.webServer/httpProtocol/customHeaders and see if any headers are added. It would look something like this (assuming that nothing else was in that web....


3

It just so happens that I recently put this function into a PowerShell web framework I write. Here's the trio of lines you'll need: Add-Type -AssemblyName System.Web $webConfigStore = [Web.Configuration.WebConfigurationManager]::OpenWebConfiguration($path) $customSetting = $webConfigStore.AppSettings.Settings["$Setting"]; The third will ...


3

[JUST A NOTE] I know this is an old one but this still deserves to noted. Scott Forsyth - MVP answer is incorrect. The ASP.NET AppDomain is restarted whenever you 'touch' web.config. This is wrong. Whisk answer is the most technically correct & complete answer as it includes a link to the MSDN that includes one important detail: When an ...


3

Pay close attention to the fact that the IIS 7.x web.config setting of noCompressionForProxies="false" Is not honored at the web.config level. It must be set in C:\Windows\System32\inetsrv\config\ApplicationHost.config like so: <httpCompression directory="%SystemDrive%\inetpub\temp\IIS Temporary Compressed Files" noCompressionForProxies="False"> ...


3

Try this - <configuration> <system.webServer> <httpErrors errorMode="Custom" defaultResponseMode="File" > <remove statusCode="404" /> <remove statusCode="500" /> <error statusCode="404" path="404.html" /> <error statusCode="500" path="500.html" />...


2

I am discovering a lot of complicated work-arounds for Classic ASP in IIS 7.5 for dealing with IIS 6 type of custom error handling for a specific error code, typically 404. I hope this helps people who stumble upon it. I am running IIS 7.5 R2 but I think this applies to IIS 7 in general. If your web.config file has this in it: <customErrors mode="On"&...


2

There may be another way, but simply you can - create a local user under Windows, - add them to a local user group, - remove anonymous access to the folder containing the web site and - change file permissions to only allow access to members of the local user group For the IP whitelist, there doesn't appear to be a way to override basic auth by IP address. ...


2

If you are using IISExpress and Visual Studio 2015, the applicationHost.config is stored in $(solutionDir).vs\config\applicationhost.config (thanks to Nime Cloud's answer). Just change overrideModeDefault="Allow" wherever appropriate. <sectionGroup name="security"> <section name="access" overrideModeDefault="Deny" /> <section name="...


2

I figured it out at last. And it's awesome! You can install IP and Domain Restrictions role service in Server Manager under Roles → Web Server (IIS) → Role Services After that you can browse IIS manager in Content View and permit/deny any file or directory you want for any IP address and also specify default action for unspecified hosts. Just select ...


2

Add a MIME type to the IIS config for the .notebook extension. You'll have to find out exactly what the mime type is to use. Maybe application/x-smarttech-notebook.


2

No, according to the documentation, isapiFilters can only be defined on the server or site level. You may put the 32bit Application into its own site and then URL-rewrite every request for it from the main site. But that may result into more problems/work depending on your application.


2

In essence, you don't need to provide a host name here, however if you do then clients must use that hostname. If you are redirecting from zuggler.com to www.zuggler.com and you want to add a host name, you only have to enter the latter. If you want people to be able to type both without redirecting, then you have to add two bindings as per below. From ...


1

Apparently you can't override this in a location tag or even in your web.config like so: <staticContent> <mimeMap fileExtension="woff" mimeType="application/x-font-woff" /> <remove fileExtension="ogg"/> <remove fileExtension="mp4"/> <remove fileExtension="webm"/> <mimeMap fileExtension="ogg" mimeType="video/ogg" /&...


1

Should Use cacheControlMaxAge="0.00:01:00" instead of httpExpires="0.00:01:00" but the latter does not throw an error, just doesn't work.


1

Press Windows+R and paste: notepad %systemroot%\System32\inetsrv\config\applicationHost.config this will bring up the main configuration file for IIS: Most changes you are making in the IIS UI that don't make it into your web.config are saved here. Towards the end is a 'handlers' node that defines how the various file types are handled, all extensions ...


1

Have an external service like Pingdom send a request to your site at whatever interval you want. Just make sure it is in fact an HTTP GET request to the URL. That should force the server to run the application. Lastly: Switch your web host provider, it will save you lots of headache down the road. I personally recommend DiscountASP.net. Great and cheap ...


1

You likely don't need to use impersonation, and in fact doing so will probably make things less secure (not least because you'd need to give each domain user rights over your SQL instance. Run the application pool as the NetworkService or ApplicationPoolIdentity, don't use inheritance, and then either give your server's computer account (JACK1$) the ...


1

HTTP 503 usually indicates that the Application Pool is unavailable for request processing. Make sure the Application Pool is running Enable Detailed Errors - but only for local requests, and then browse the web app from the server itself If that doesn't yield any results, enable Failed Request Tracing, browse the site again, and review the Failed request ...


1

I think your problem is a pure WordPress settings issue. The rewrite rules from your post are only important for incoming requests. I.e. they rewrite the URL from an incoming request to the index.php page. They are of no importance for any URL's generated by WordPress and that's clearly where your problem is. My guess is that you have not properly ...


Only top voted, non community-wiki answers of a minimum length are eligible