Hot answers tagged

4

Don't use the aggressive mode, the connection will be less secure. Anyway try with this configuration. I use it on a my VPN Server with strongswan-5.3.5 and xl2tpd-1.3.6 ipsec.conf config setup cachecrls=yes uniqueids=yes charondebug="" conn %default keyingtries=%forever dpddelay=30s dpdtimeout=120s conn L2TP dpdaction=clear ...


2

In case anyone else comes across this, here is the script I ended up using. It searches /var/log/messages for log in messages, then checks if the PID is still in use by pppd. It outputs just the user name and when they logged in. #!/bin/bash # Process each log in message grep "logged in" /var/log/messages | grep pppd | while read -r line ; do #echo "$...


1

There is a known bug in Linux kernel 4.15, which Ubuntu 18.04 ships, that causes the IP address to change in this way. It was caused by 5efec5c655dd ("xfrm: Fix eth_hdr(skb)->h_proto to reflect inner IP version") and was later fixed with 87cdf3148b11 ("xfrm: Verify MAC header exists before overwriting eth_hdr(skb)->h_proto"), which was part of the 4.16 ...


1

Disclosure: I am the author of the GitHub repository you linked to. The Linux client setup instructions have been re-written on 10/19/2016. Check out the updated instructions at: https://github.com/hwdsl2/setup-ipsec-vpn/blob/master/docs/clients.md


1

I highly doubt this is possible. L2tp works over udp/1701, and it's not proxiable. Furthermore, you don't need to proxy it, because pure l2tp is perfectly able to cross NATs. After all, your request looks like a wrong solution to a common problem. Please describe initial problem, and may be we will be able to provide a solution simple enough.


1

For Windows users, a registry change is required to be able to connect to an IPsec/L2TP VPN behind NAT (e.g. in EC2). Please follow these instructions. Scroll down to the bottom to view separate steps for Windows XP, and for Vista, 7, and Server 2008.


1

add "ATTRIBUTE Acct-Interim-Interval 85 integer" to /etc/radiusclient/dictionary and return Acct-Interim-Interval in /etc/raddb/users or radreply sql table or others ways you like. here is the solution: http://lists.freeradius.org/pipermail/freeradius-users/2007-March/016817.html


1

In your /etc/ppp/options.xl2tpd file you have 'idle 1800', that is 30 minutes. You could try setting that value to a higher number or do something terrible like the following: while true; do echo "c default" 1>/var/run/xl2tpd/l2tp-control; sleep 1500; done


Only top voted, non community-wiki answers of a minimum length are eligible